Starcraft 2 is crashing during the game NOTD

Discussion in 'NOTD Discussion' started by bischop, Feb 23, 2012.

  1. bischop

    bischop New Member

    Hi there,

    Since few days (since some kind of last Windows update, NOTD update[*] and Starcraft 2 patch 1.4.3 - all of those patches were almost in the same time) every time when im starting the game NOTD my SC2 is crashing during first few minutes of the game. WTF? I tried everything:
    - i turned off UAC in Windows
    - turned off firewall
    - deleted SC2 "cache" folders/files
    - i reinstalled game Starcraft 2
    - installed anty-virus application (no viruses found)
    - closed all other applications from background

    What can i do to fix it or to let me know wtf can be wrong?

    Everything was good before those patches and maybe before something else. On my 2nd PC i got Starcraft2 and its runing fine on the same SC2 account. I coped bank files between those machines, but i didnt tried to delete them and play on "clear" account.


    [*] NOTD update was after my game started to crash i think.
  2. Ghost
    • Warden

    Ghost Warden

    Then it might be a Windows issue if it occured prior to a NOTD and SC2 update.
  3. Lord NiteShade
    • Wiki Founder
    • Community Leader

    Lord NiteShade NOTD Staff: Wiki Founder/TeamSpeak Admin

    If it happens at the same period ingame, such as a chapter change, or boss appearance, it could be that old sound bug rearing its head again. Certain sound cards (or was it drivers?) would crash when they tried to load various music. I hoped it had been ironed out.

    If it's not that, then I'd have to say try the old "uninstall reinstall" approach.
  4. bischop

    bischop New Member

    Yes, it might be. But i dont know how to find the issue. Windows is almost fresh installation - about 1-2 week old. It's Windows 7 Ultimate x32 SP1 (x32 not x64 - on x64 every thing was ok). But it's not x32 version problem cuz after installation game was worked fine.

    Maybe in Starcraft 2 logs i can find the answer was was wrong?

    Update: I checked logs folder and i found those informations inside several files:

    Code:
    GameData\ActorData.xml(9514,9) : Unable to write value: 0.000000; reason: Core: invalid object type identification
     Source: C:/ProgramData/Blizzard Entertainment/Battle.net/Cache/d2/7e/d27ef4ef2abd4460608c8d021fcdd44c6b0497944e843ffcad2251e59fa4df46.s2ma
     Entry: InfernoBlast
     Scope: CActorModel
     Field: Scale
    I removed again folder "C:/ProgramData/Blizzard Entertainment" and then i will change access privilages for this folder.

    Code:
    e_errorIdMemory
    "Core: out of memory"
    (3,600,000 bytes)
    Have no idea it's main memory or GPU memory. And why i have those msg when everything was ok few days before.

    Code:
    e_gfxErrorOutofMemory
    "StarCraft II has encountered an error. Your graphics system may be running low on available memory. Please restart your machine. (...)
    So it's GPU memory. But dont know how to incrase few megabates of it. Im playing ofc on low detail settings.
    Graphics card is: Nvidia Geforce 9500 GT 512MB
    Graphics driver version: Nvidia 275.33 (same shit happends on 285.62 so it's not matter of drv version)
    CPU: AMD X2 3800+
    RAM: 3 GB

    Maybe the problem is with x32 bit of Windows. I got 3 GB main ram and additional GPU ram 512 MB. Windows 7 x32 can address ... let me check - Windows_7 # Physical_memory_limits .. hmm 4 GB. So it's not the problem of Windows 7 x32. Dunno then.

    I little changed Virtual Memory paging file settings in Windows and we will see. But i dont think tats the problem the more that error logs from SC2 said "graphics system may be running low on available memory" not "main memory".

    Update:
    Still same shit. In log file: "Core: out of memory".
  5. Earendil

    Earendil New Member

    Try lowering graphic settings?
  6. bischop

    bischop New Member

    On tat matchine im already playing lowest settings all the time.
  7. Diode

    Diode Well-Known Member

    Then your video card can't support it. Its burning up and leaking.
  8. bischop

    bischop New Member

    Well i was thinking the same but:
    - game was working fine 2 weeks ago
    - temp. on GPU is max 49'C (tested by GPU-Z application)
    - 3DMark 2006 is working fine (without any errors/crashes)
    - ladder games (3v3, 4v4, 1v1 koth+obs) in Starcraft 2 are working fine (without any errors/crashes)

    so i dont think its graphics card problem.
  9. Diode

    Diode Well-Known Member

    Ladder games don't generate 1000000000000000000 effects and particles.
  10. bischop

    bischop New Member

    So try to play 4v4 in high-master league with 3-6 zergs on the map then you will see how many units are on the map after 15 min of the game. Remember im playing all the time on "low settings".

    I tested stability on 3DMark2006 as well. It wasnt only 1 run, but loop. I stopped it after about 3-4 cycles.

    I can try to lunch another stability test - just tell me name of it.

    Update:
    I re-lunched 3DMark2006 this time on 1920x1080, AA 8-samples AA, Anisotropic filtering - 1 sample.
    Temperature this time is 54'C.
    Result: 1393
    Result: 1255 (AA Quality 2, Anisotropic level 2)

    Looped for about 45 min still no crash.
  11. ArcanePariah
    • Development Team
    • Map Developer

    ArcanePariah Miracle Worker

    I would disable AA, it doesn't add much to a RTS style game, the units are too small usually to notice, and your moving your map view around too much usually.
  12. bischop

    bischop New Member

    Ofc, but the point was to make GPU hot by load it as much as possible. And it's working stable.

    Im going to sleep right now, but tommorrow i will try to install some other gpu/cpu benchmarks.
  13. fox

    fox New Member

    Sounds similar to the "SC2 empty object" bug we had a few patches ago.

    This may or may not work for you but is worth a try. Try option 1 before attempting option 2.


    Option 1: Enable Vertical Sync

    -In SC2, go to Options > Graphics
    -Under Display check the box for "Vertical Sync"
    -Close and restart SC2, then go back to Options > Graphics and make sure the "Vertical Sync" box is still checked
    -Now go play some NOTD and see if it still crashes at the same place


    Option 2: Rebuild "Variables.txt"

    -Locate "Variables.txt" in your player profile. This is usually under
    Documents\StarCraft II\Accounts\xxxxxxxxx\ where xxxxxxxxx is a series of number unique to your player ID
    -Copy and backup the Variables.txt to other media. You may wish to restore it later
    -Once the file is backed up, go back to where you find the Variables.txt under your profile folder
    -Make sure SC2 is closed properly and delete the Variables.txt
    -Restart SC2 and go to Options > Graphics. Make sure everything is set to minimum settings and Vertical Sync box is checked
    -Now go test out NOTD and see if problem still occurs


    Note: Option 2 is no way a "fix," more like a work around. Even if it works for you the first time, you may or may not have to repeat the entire process again for every single game. Only use it if you're desperate!

    Anyway, let us know if these options work for you.
  14. bischop

    bischop New Member

    #1 solution not working. I did it and i was dropped after 35 min of the game.
    But i need to say:
    1) I turned ON v-sync in SC2 but i got "v-sync force off" in nvidia drivers settings.
    Now i switched in drivers settings to "application decided" and will try again
    2) I didnt tried removing file "variables.txt" yet, but ... long time ago i modify this file and i changed some options in it. SC2 was working but after i installed new Windows (this time x32, was x64 before) maybe i had to remove this file and let SC2 re-creating it. Now i will test again 1st solutuion and then we will see.

    Update:
    crashed after first 1-2 min of the game.

    Update:
    Game was long for about 44 min but still NO crash (i was killed in the game). I will test it few more times later - maybe it's fixed now.


    Ok, i will try with #2 solution now.
  15. fox

    fox New Member

    Looks promising...

    Yeah vsync sometimes fixes simple problems so it's worth a shot. It acts like a speed limit for your gfx so it can't overload (software and hardware) by going over 60Hz.

    Do follow up on the outcome, as others may have similar problem and they can benefit from this post.
  16. Diode

    Diode Well-Known Member


    Are you playing in full screen or window mode? If window mode your raping your GPU twice as hard then full screen. Since your already playing at lowest settings it doesn't help at all.
  17. bischop

    bischop New Member

    "Fullscreen" only.
    Never have more than 30 fps during the game (On the begining of the leagues matches - yes, about 50-60 fps, but only on the beginig cuz later 1-30 is max, usualy 1-15).
  18. Diode

    Diode Well-Known Member

    Then your playing on borrow time. Your card will give out soon. SC2 is known to kill GPUs if you have the lower end model. I burn out one already.
  19. bischop

    bischop New Member

    I removed Variables.txt, v-sync is ON (SC2 and nvidia drivers).
    I played alpha and no crash in the game (we finished this game with success).
    But its alpha not easy-company. Now if nothing will happend on easy-company problem will be solved.

    Update:
    i finished easy-company without crash. So i think solution is working.
  20. lafalot

    lafalot New Member

    Bumping to say Option #2 worked!

    I had the exact same errors as bischop:

    - random crashes from loading screen to 1-2 mins into the game to 20 mins into the game
    - logs say "core: out of memory" even though I have 4 gigs of ram with radeon 4850
    - running on low settings did not fix the problem

    My laptop has an i3 and 540m which slows down when busy and yet never crashed so I knew the "out of memory" was not really true.

    Thanks!
    v 1.269

Share This Page