Bugs from Patch 2.0.4

Discussion in 'Archive' started by ArcanePariah, Feb 19, 2013.

  1. ArcanePariah
    • Development Team
    • Map Developer

    ArcanePariah Miracle Worker

    Ok so a number of bugs/changes have occured as part of the Blizzard patch (What else is new). If you find anything that is now broken that was working before, report it here so I can priortize them and get them fixed for next patch. I'll keep a running list here, collecting all reports into this post. Will note things I have fixed in current development build.

    Current Bug List

    - Marksman does not use his attack animation (Resolved)
    - Tooltips are placed on right side of screen
    - Menu Button is on bottom right and covers Social button (Resolved)
    - Mission Objective background image is too small
    - Storyline selection text is mismatched (Resolved)
    - Crashes on load (Forerunner) (Resolved)
    - Shop is non functional in Alpha Company (Wolf)
    - Nanoweave hotkey is not present (Wolf) (Resolved)
    - Grenade hotkey is not present (Wolf) (Resolved)
    - Fireup Level 1 and 2 do not provide bonuses to Focus Fire (Wolf) (Resolved)
    - Erebos 2 does not unburrow (Resolved)
    - Demo Build Mines produces 1 less mine then should (Resolved)
    - Demo Mines provide 1 less mine then should
    - Technician has Marauder model appear on sides (Resolved)
    - GotB charge is enabled in all modes
    - Rifleman is not team colored (Resolved)
    - Demeter Attack animation lacks model
  2. TheWolf
    • Donator

    TheWolf Surgeon of Death

    okay so i just rename em all i found so far:
    1. Shop doesnt work (at least in ac nm)
    2. Nanoweave hotkey w missing
    3. Roflmans grenade hotkey E mssing
    4. Rofls Fire Up lvl 1 n 2 dont give attackspeed bonus. 3 does but not sure if right amount
  3. Niktos

    Niktos Well-Known Member

    Done some fast test and:
    Shop bug-> ac broken, ec/sec shop works fine, in surv only ec truck works
    Nanoweave/granade hotkeys->it`s setting based most likely as i have those hotkeys and they work fine [i have classic hotkeys as per sc2 settings]
  4. Scorpione

    Scorpione Well-Known Member

    My custom hotkeys all work fine... I'm guessing this is only for weird preset/customs hotkeys.
    Switched to standard also works.
  5. ArcanePariah
    • Development Team
    • Map Developer

    ArcanePariah Miracle Worker

    the hotkeys are fine, the issue is of display i believe
  6. Scorpione

    Scorpione Well-Known Member

    Not sure, I cannot say I recall seeing missing display letters. They are pretty acute on the command card. Being the pain in the ass that I am I would've noticed.
    If the hotkey itself works it automatically gets displayed if the setting is on. Even if you have 3 overlapping hotkeys being used. E.g. "G" on granade and nuke.
  7. DLINK

    DLINK Well-Known Member

    NOTD is crashing for me at the loading screen as well. All 3 times I've tried to load it "An unexpected fatal error occurred.", rather than my usual "Core out of memory" or "Out of video memory" messages. Does anyone have this problem loading other arcade games?

    Off-topic:
    Melee game endgame scorescreens are all screwed up as well. Scores dont match up and completely fucked up units in build order screen :p EDIT: nvm, that was probably because I didn't go online before playing a game.
  8. Scorpione

    Scorpione Well-Known Member

    Should be missing files/corrupted. Those are usually fatal errors causes.


    Unless a wild bug has appeared. Mighty AP use resolve :D
    SN: re updating/repair should solve it if it is missing/corruption
  9. Froblock

    Froblock Well-Known Member

    Looks like Blizzard has enabled ragequit troll mode.
    This happens in sc2, period. Pause the game and quit.
    The remaining players will have no control over any unit on the map nor will be able to move their screen anywhere. It would appear that you are paused when resumed.
  10. HipHopDragon
    • Warden

    HipHopDragon Warden

    Demeter is playing bowling now.
    When he attack he throws big white balls at players, posting pic after game.
  11. DLINK

    DLINK Well-Known Member

    Just finished repairing my sc2 and still crash on loading screen. How would I reupdate? Do I delete the new HOTS files, and if so, which ones are they?

    and (not) surprisingly, I can still load NOTD on the older version of sc2 via replays, if that helps any.
  12. Blaze

    Blaze New Member

    Bug? i cant select anything other than my own character and im getting no lag but massive delay between commands
  13. HipHopDragon
    • Warden

    HipHopDragon Warden

    thats a new selection option of sc2 blaze.

    edit: and the delay might be because your graphics were set to ultra.
  14. Blaze

    Blaze New Member

    lowest of the lows with resolution low as hell
  15. HipHopDragon
    • Warden

    HipHopDragon Warden

    some people reportet that its laggy for them after the patch, might be that. Otherwise i have no idea for that if your setting are the same.
    [hr]

    ---


    After a pause noone was able to do anything. At the start it was a mega lag festival then one dropped we paused and after the unpause noone could do anything.
    [hr]
    Screenshot of demeter attack. Demeter just died only his attack is left there.

    Replay of the no control bug.
  16. DLINK

    DLINK Well-Known Member

    Apparently I can't even watch the current NOTD replays anymore. Couldn't get HipHop's replay to even start loading, no info showed up when I highlighted his replay in sc2 replay menu and it just says "unable to open replay".
  17. Lyanden

    Lyanden Well-Known Member

    I'm now afraid to even log onto starcraft2 as our specs are quite similar.

    :s
  18. DLINK

    DLINK Well-Known Member

    I don't think that's the problem, seeing as how I can load/play other big arcade maps (usual lag, but what else is new?). I don't think my mapfile is corrupted (cleared sc2 cache and redownloaded NOTD), so I guess I'll completely delete/redownload sc2 overnight and see how that goes.
  19. EdowardoLMP

    EdowardoLMP Well-Known Member

    Could be the new function of replay cause this. Anyone tried the "take over" (or w/e it's called) function ?
  20. JAW

    JAW Well-Known Member

    Just thought you guys should know, the patch says it's 100% completed at around 8 GB, but the total size is 14 GB, so whatever you have left over will continue to dl in the background while sc2 is running. Try letting the sc2 launcher finish dling and see if that helps the lag/other issues.

Share This Page